أخر الاخبار

كيفية استعمال الدالة SIERREUR في الاكسل

 

كيفية استعمال الدالة SIERREUR في الاكسل


في هذه المقالة سيتم التطرق لشرح كيفية استعمال الدالة SIERREUR والتي تعتبر من الدوال المهمة في الاكسل.

تتحقق الدالة SIERREUR من Excel مما إذا كانت القيمة المدخلة خطأ ، ثم تقوم بإرجاع نفس القيمة إذا لم يكن هناك خطأ أو تم تحديد قيمة أخرى في حالة حدوث خطأ.


=SIERREUR(valeur, valeur_si_erreur)



حالة عملية

لنأخذ مثال وظيفة RechercheV التي تعرض عدد النقاط وفقًا لرقم الملف الذي تم إدخاله:


كيفية استعمال الدالة SIERREUR في الاكسل



المشكلة في هذه الحالة هي أنه سيتم عرض خطأ إذا لم يتم العثور على نتائج:


كيفية استعمال الدالة SIERREUR في الاكسل


بدون وظيفة SIERREUR، سيتعين علينا استخدام الدالة SI بالإضافة إلى وظيفة أخرى لاختبار ما إذا كانت الدالة RechercheV تُرجع خطأً وإرجاع نتيجة دالة RechercheV إذا كان كل شيء على ما يرام أو قيمة أخرى في حالة حدوث خطأ:

=SI(ESTERREUR(RECHERCHEV(E2;A2:C11;3;FAUX));"-";RECHERCHEV(E2;A2:C11;3;FAUX))

لذلك فإن الصيغة طويلة بشكل غير ضروري ووظيفة RechercheV موجودة مرتين ...

تتيح الدالة SIERREUR تبسيط كل هذا عن طريق اختبار قيمة وإرجاع هذه القيمة نفسها مباشرةً إذا لم يكن هناك خطأ (أو خطأ آخر في حالة حدوث خطأ):

=SIERREUR(RECHERCHEV(E2;A2:C11;3;FAUX);"-")


كيفية استعمال الدالة SIERREUR في الاكسل



تعليقات
ليست هناك تعليقات
إرسال تعليق



    وضع القراءة :
    حجم الخط
    +
    16
    -
    تباعد السطور
    +
    2
    -